Unidac Postgres - Postgres 14 and older UniDAC postgres

Unidac Postgres - Postgres 14 and older UniDAC postgres

I had to rebuild my old dev environment and installed newer Postgres version, previously had 9.x and went to 14.   I have resolved the error, but want to share my solution here.   this link let 

When developing with older unidac 8.4  I ran into issue where I was getting an error  p.adsrc not found.  Turns out  Postgres depracated use of  of that to get default value.  Fortunately I had access to source and was able to patch the file   PgClassesUni.pas

Line 8285  changing  pd.adsrc to pg_catalog.pg_get_expr(pd.adbin, pd.adrelid) as adsrc

I was able to build my app and all is well now.

Have this been corrected in the current versions of UniDac.  Is there a provision to use with older Postgres versions via include file ? 

I have not tried against a PG 9 db, but my prior compiled app works against  AWS RDS postgres which is very current, so it appears to be more of a designtime problem for me, but as I stated i have not tested this beyond my narrow use case.